// Bad, the type tells us what these variables are: String nameString; List<datetime> holidayDateList; // Better: String name; List<datetime> holidays;
// Overly specific names are hard to read: Monster finalBattleMostDangerousBossMonster; Payments nonTypicalMonthlyPayments; // Better, if there's no other monsters or payments that need disambiguation: Monster boss; Payments payments;
// Bad, repeating the context: class AnnualHolidaySale {int annualSaleRebate; boolean promoteHolidaySale() {...}} // Better: class AnnualHolidaySale {int rebate; boolean promote() {...}}